cordova build of viewer app failing on android 6.0.1

Ask, and ye shall receive.
pjdowner
Posts: 1
Joined: 20:07, 19 Apr 2016

cordova build of viewer app failing on android 6.0.1

Postby pjdowner » 20:25, 19 Apr 2016

Hi,

I'm just getting started with evothings, I've been trying to build my own cordova app, but I've temporarily given up and switched to trying to build the evothings viewer with cordova from the master branch of https://github.com/evothings/evothings-viewer and whilst it runs it's failing to find devices, I get nothing reported in the console.log when remote debugging with chrome or in the evothings workbench tools log. However in adb logcat I get:

Code: Select all

04-19 19:19:40.527  2480  2777 D BtGatt.GattService: start scan with filters
04-19 19:19:40.528 27837 27849 W Binder  : Caught a RuntimeException from the binder stub implementation.
04-19 19:19:40.528 27837 27849 W Binder  : java.lang.SecurityException: Need ACCESS_COARSE_LOCATION or ACCESS_FINE_LOCATION permission to get scan results
04-19 19:19:40.528 27837 27849 W Binder  :      at android.os.Parcel.readException(Parcel.java:1620)
04-19 19:19:40.528 27837 27849 W Binder  :      at android.os.Parcel.readException(Parcel.java:1573)
04-19 19:19:40.528 27837 27849 W Binder  :      at android.bluetooth.IBluetoothGatt$Stub$Proxy.startScan(IBluetoothGatt.java:772)
04-19 19:19:40.528 27837 27849 W Binder  :      at android.bluetooth.le.BluetoothLeScanner$BleScanCallbackWrapper.onClientRegistered(BluetoothLeScanner.java:324)
04-19 19:19:40.528 27837 27849 W Binder  :      at android.bluetooth.IBluetoothGattCallback$Stub.onTransact(IBluetoothGattCallback.java:56)
04-19 19:19:40.528 27837 27849 W Binder  :      at android.os.Binder.execTransact(Binder.java:453)


The geolocation plugin is installed which I believe this error relates to, although I have just updated my phone to Android 6.0.1 so there may be some new permissions required on the latest version? However oddly enough the version of the viewer I had installed on my phone earlier (before removing it to install my own build) which was from the google play store, worked fine on Android 6.0.1

Does anyone know how I can add these permissions to the viewer app?

User avatar
micke
Posts: 256
Joined: 20:49, 18 Nov 2013

Re: cordova build of viewer app failing on android 6.0.1

Postby micke » 19:47, 20 Apr 2016

Hi, this could be a related issue: https://github.com/evothings/cordova-ble/issues/87

Added a note to the above issue about the permissions mentioned in your log.

Working on a new version of Evothings Viewer, will look for this problem.

Many thanks for reporting this!

Best, Mikael

User avatar
micke
Posts: 256
Joined: 20:49, 18 Nov 2013

Re: cordova build of viewer app failing on android 6.0.1

Postby micke » 20:36, 28 Apr 2016

Hello again, have been working on a solution to this issue.

The result is pushed to the master branch of the BLE plugin.

For further details see this issue: https://github.com/evothings/cordova-ble/issues/87

User avatar
micke
Posts: 256
Joined: 20:49, 18 Nov 2013

Re: cordova build of viewer app failing on android 6.0.1

Postby micke » 19:27, 01 May 2016

Published new version of the BLE-plugin with support for Android 6:

https://github.com/evothings/cordova-bl ... /tag/1.3.0

Follow this issue for further progress:

https://github.com/evothings/cordova-ble/issues/87


Return to “Questions and answers”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests