Page 1 of 1

BLE scan example doesn't find devices

Posted: 12:22, 06 Apr 2016
by jevoyat
I just wanted to start somewhere, so I tried the "ble scan" example.
It loads and start correctly, but after pressing "start scan" it just keeps showing "scanning..." .

From my phone BT settings I see a device (Selfie Shutter) that I activated on purpose (not paired).

I am using a phone with Android 5.1.1


Re: BLE scan example doesn't find devices

Posted: 12:51, 06 Apr 2016
by alex

BLE scan is reasonably reliable, while all devices don't announce. But if you're in an environment with several devices, and they don't show up in the app while they do show up under Settings>Bluetooth, there is something fishy going on.

Is there any info under Tools in the workbench? What kind of phone do to have, is it an older one and does it have BLE?
Devices under Bluetooth Classic don't show, only BT 4.x devices.



Re: BLE scan example doesn't find devices

Posted: 14:20, 08 Apr 2016
by jevoyat
apparently the remote control for shutting pictures doesn't use a BLE, but a normal BT ...
I tried with an RFduino and it is correctly detected.

Thank you very much.

just another newbie point. Clicking on "Tools" the "JavaScript Workbench" is opened. In the upper part there are some JS commands; in the lower part I get the results of evaluating. How am I supposed to receive error messages from the actually running app ?

Thanks again !


Re: BLE scan example doesn't find devices

Posted: 13:03, 14 Apr 2016
by Fredrik
Most of our example apps have this little snippet at the top of the HTML file:

Code: Select all

   // Redirect console.log to Evothings Workbench.
   if (window.hyper && window.hyper.log) { console.log = hyper.log }