$ajax redirect issue

Ask, and ye shall receive.
dbrendon
Posts: 3
Joined: 17:02, 02 Mar 2016

$ajax redirect issue

Postby dbrendon » 17:12, 02 Mar 2016

Hello,

I have modified the example TI CC2650 sensor demo so that it makes an ajax call to a REST web service under certain conditions. I have confirmed the web service runs (it creates a WorkOrder in the system), but the ajax call always executes the 'error' call back - not the 'success' callback. The response does not contain the expected json message.

This is the response from the error callback:
{"readyState":0,"responseText":"","status":0,"statusText":"error"}

[EDIT]
Some additional information: the jqXHR.state() is 'rejected'

In the error callback I added a log message for location.href:
LOG: location.href: https://us-west-2-deploy.evothings.com/hyper/..... /index.html
/[EDIT]

I have tested the web service call with SOAPUI and it always completes successfully and returns the expected json message.

From my investigation I suspect that this has something to do with a redirect - or with access-control-allow-origin.

Can anyone provide a suggestion to overcome this issue? Or to further confirm the nature of the error?

Thank you,
- David

WalterEt
Posts: 1
Joined: 21:09, 01 Mar 2016
Location: Spain
Contact:

ajax redirect issue

Postby WalterEt » 07:59, 03 Mar 2016

I have already done this with the same results. This issue only started to happen after this recent update. How can i solve it?
Essay help you need! High-quality essays only!

dbrendon
Posts: 3
Joined: 17:02, 02 Mar 2016

Re: $ajax redirect issue

Postby dbrendon » 17:42, 03 Mar 2016

WalterEt wrote: This issue only started to happen after this recent update.


Which update are you referring to?
Is it possible to revert to an older version?

Thanks,
- David

dbrendon
Posts: 3
Joined: 17:02, 02 Mar 2016

Re: $ajax redirect issue

Postby dbrendon » 22:11, 04 Mar 2016

<bump>


Return to “Questions and answers”

Who is online

Users browsing this forum: MSN [Bot] and 6 guests