'vibrate' doesn't work on iOS 8?

Ask, and ye shall receive.
andi7
Posts: 4
Joined: 10:10, 12 Nov 2014

'vibrate' doesn't work on iOS 8?

Postby andi7 » 10:20, 12 Nov 2014

I recently experimented with the Evo app and tried out some features including the vibrate function.
As the title suggests, it didn't work on iOS 8 (iPad), but works on iOS 7 (iPhone).

Is there a known issue about that, did something change with the API?
Help is greatly appreciated.

User avatar
micke
Posts: 256
Joined: 20:49, 18 Nov 2013

Re: 'vibrate' doesn't work on iOS 8?

Postby micke » 11:33, 12 Nov 2014

Hi Andi, from what I know the iPad does not have a vibrator built in. I get the same behaviour. It would be useful/fun to have a vibrator also on the iPad. It is the same with Android tablets I have tested. Perhaps this is to save weight/space or something (perhaps you need a bigger vibrator on a tablet).
Best regards, Mikael

Fredrik
Site Admin
Posts: 196
Joined: 15:00, 18 Nov 2013

Re: 'vibrate' doesn't work on iOS 8?

Postby Fredrik » 11:33, 12 Nov 2014

I've just tested both an iPhone and an iPad with iOS 8. Only on the iPhone did vibration work.

Official documentation is unclear, but Apple forum threads suggest that no model of the iPad has vibration hardware.

So... not a bug.

andi7
Posts: 4
Joined: 10:10, 12 Nov 2014

Re: 'vibrate' doesn't work on iOS 8?

Postby andi7 » 11:45, 12 Nov 2014

I haven't considered this possibility :D Never thought about that. Makes sense, though...
Thanks for the fast reply.


Return to “Questions and answers”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests