iBeacon demo not working on iPhone 6

Discuss the company and its products.
Justin
Posts: 5
Joined: 15:24, 16 Dec 2014

iBeacon demo not working on iPhone 6

Postby Justin » 16:15, 16 Dec 2014

Hi all,

I've produced an app that's based on the Evothings iBeacon Demo app; the "user facing" functionality of the app is different but it re-uses the scanning functionality from the iBeacon Demo app. "That's all very well, but why should I care?" I hear you say - well, the odd thing is that the app works as expected on an iPhone 5s, but not an iPhone 6, or 6 plus. See the screenshot below to see the app happily detecting a BlueCats iBeacon on the 5s and completely ignoring the beacon on the 6.

Both phones are running iOS 8.1.2, the only difference as far as I'm aware is the hardware itself.

Is anyone else having similar issues? Does anyone have any interesting theories?

Thanks, and have a Happy Christmas,
Justin
Last edited by Justin on 10:26, 23 Oct 2019, edited 2 times in total.

User avatar
micke
Posts: 256
Joined: 20:49, 18 Nov 2013

Re: iBeacon demo not working on iPhone 6

Postby micke » 21:33, 17 Dec 2014

Hi Justin,

Thanks a lot for reporting this, we will take a look and investigate how iBeacons work on iPhone 6.

Have you had a chance to test the iBeacon Scan example app that comes with Evothings Studio? Does it work?
Does the BLE Scan example show your beacons?

Is you app a Cordova app or do you use Evothings Client? If you have built a Cordova app, do you know which version of the iBeacon plugin you are using? It might be the iBeacon plugin that is not working for iPhone 6.

Thanks again for reporting, indeed most relevant!

Best regards, Mikael :)

Justin
Posts: 5
Joined: 15:24, 16 Dec 2014

Re: iBeacon demo not working on iPhone 6

Postby Justin » 15:46, 18 Dec 2014

Hi Mikael,

Thanks for the reply, and thanks to you and the EvoThings team for a fantastic product. :)

I can confirm the EvoThings iBeacon Demo app does not work on the iPhone 6 either. Looks like there's an issue specific to the Bluetooth stack on the iPhone 6 and 6 plus.

My app was deployed within the EvoThings client, I've been having issues getting a Cordova app to work properly but that's a whole other topic and not for discussion here - it's almost certainly down to something I'm doing wrong. ;)

I'll conduct some further investigation, but I'm stronger on the Android side than on iOS, so my progress may not be swift (pardon the pun).

Cheers,
Justin

Fredrik
Site Admin
Posts: 196
Joined: 15:00, 18 Nov 2013

Re: iBeacon demo not working on iPhone 6

Postby Fredrik » 16:16, 18 Dec 2014

We've just tested our "iBeacon Scan" example on an iPhone 6 Plus with iOS 8.2 and Evothings Client 1.1.0 (recently released on the App Store). It works normally.

Perhaps you've accidentally set "Don't allow" for access to the Location API for Evothings Client on your phone?

What, exactly, happens when you run the "iBeacon Scan" example?

Justin
Posts: 5
Joined: 15:24, 16 Dec 2014

Re: iBeacon demo not working on iPhone 6

Postby Justin » 17:03, 18 Dec 2014

Hi Fredrik,

Enabling location services for the Evothings client did the trick, thanks!

Interestingly, this is a brand new iPhone and I hadn't updated any location services settings on it as far as I'm aware.

When I drilled into Settings -> Privacy -> Location Services, Evothings was listed but there was no policy displayed for it.

As a sanity check, I uninstalled Evothings client on my iPhone 5s and then reinstalled it. The Location Services policy was blank by default and I was then able to recreate the problem on the 5s too (selecting "Always" or "While Using" solves the issue, as expected) - see screenshot below.

Just wondering - is the Location Services policy defined within the Evothings Client app configuration when you build it, and has this recently changed? As things stand, apps running inside Evothings client on iOS won't detect beacons unless the user intervenes, which I'm thinking is probably not the desired behaviour.

Thanks for helping me get to the bottom of this. :)

Cheers,
Justin

Screenshot follows:
IMG_0198.PNG

User avatar
micke
Posts: 256
Joined: 20:49, 18 Nov 2013

Re: iBeacon demo not working on iPhone 6

Postby micke » 17:09, 19 Dec 2014

Hi again Justin,

Very cool that it works now.

What the iBeacon Scan app does is that it calls:

Code: Select all

locationManager.requestAlwaysAuthorization();


This should pop up a dialog asking for permissions, if the app is freshly installed.

Did you see this dialog after the fresh install?

Have seen that sometimes the settings dialog is not displayed, think this is after settings have been altered manually. Or if you press deny first time in the dialog, then you have to update the settings manually. I have done some testing today and the dialog shows shows after an uninstall/reinstall of the app (tested on iPad Mini iOS 8).

The actual settings for location services (the text in the dialog box) are made in the .plist file in the Xcode-project.

Let me know how it goes, it is weird that you don't get the dialog.

Best, Mikael

Justin
Posts: 5
Joined: 15:24, 16 Dec 2014

Re: iBeacon demo not working on iPhone 6

Postby Justin » 10:40, 20 Dec 2014

Hi Mikael,

I honestly don't remember seeing the dialog, and as you can see from the screenshot location services is enabled for other apps. Very odd.

I'd put this completely down to my error were it not for the fact that it was initially reported by my colleague, when he was unable to get my demo app runnin gon his iPhone 6 plus. Having said that, it doesn't seem anyone else is having this problem, so maybe we both made the same mistake. ;)

Thanks for all your help with this, I'll have a go at diagnosing the issue in more detail over Christmas and report back if I find anything that might be useful to you and the team.

Merry Christmas, :)
Justin


Return to “General discussion”

Who is online

Users browsing this forum: No registered users and 7 guests